Поиск

Ну и рукожопый же я…


Поломал себе qt-creator: сначала у меня после очередного обновления отвалились все культевые приложения. А нормальному обновлению qt мешал слишком старый creator. ОК, сносим и обновляем. А дальше… Версии 4.6 уже нет в основном дереве portage. А версию 4.8.2 я не смог поставить: после полутора-двух часов компиляции gcc выдавал ошибку.
Поставил глючный 4.10.1 в надежде, что заработает-таки.
Увы, как она ни плакала… Не работает clang’овский анализатор в 4.10!!! И ничего с этим не поделать. А мне предстоит в ближайшее время тонну кода перелопачивать + писать автоматизацию на роботелескопы.
Придется искать еще какое-нибудь IDE, которое не будет обладать такими глюками.
Замучился я, честное слово, с этими IDE! Ну где оно — безглючное IDE, где будет работать clang’овский анализ и нормальная навигация по коду, и оно не будет зависеть от самых гадких линуксовых библиотек: Qt или GTK? eddy_em.livejournal.com

Добавить комментарий